Migration to version 3

Version 3 is essentially fully backwards compatible with previous versions, with one key exception: Zend\Config\Factory no longer requires usage of zend-servicemanager for resolving plugins.

The reason this is considered a backwards compatibility break is due to signature changes:

If you were extending the class, you will need to update your signatures accordingly.

This particular update means that you may use any PSR-11 container as a reader or writer plugin manager, and no longer require installation of zend-servicemanager to use the plugin manager facilities.